1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wmv not playing in media player classic

Discussion in 'Video - Software discussion' started by kcerica, Apr 27, 2010.

  1. kcerica

    kcerica Member

    Jan 7, 2009
    Likes Received:
    Trophy Points:
    I don't have windows media player so I use the media player classic and never had any problems with play back until now, (I got it with the k-lite mega codec pack so I have all of the codecs, or should have all of the codecs I need.) The video shows up but no sound. I have wmv checked for file association in the options. Other videos with different extensions work.
    This is the error message:

    Media player classic could not render some of the pins in the graph, you may not have the needed codecs or filters installed on the system. The following pin(s) failed to find a connectable filter:

    Media Type 0:
    Audio: Windows Media Audio 16000Hz mono 16Kbps

    majortype: MEDIATYPE_Audio {73647561-0000-0010-8000-00AA00389B71}
    subtype: Unknown GUID Name {00000161-0000-0010-8000-00AA00389B71}
    formattype: FORMAT_WaveFormatEx {05589F81-C356-11CE-BF01-00AA0055595A}
    bFixedSizeSamples: 1
    bTemporalCompression: 0
    lSampleSize: 640
    cbFormat: 28

    wFormatTag: 0x0161
    nChannels: 1
    nSamplesPerSec: 16000
    nAvgBytesPerSec: 2000
    nBlockAlign: 640
    wBitsPerSample: 16
    cbSize: 10 (extra bytes)

    0000: 61 01 01 00 80 3e 00 00 d0 07 00 00 80 02 10 00 a...€>..Ð...€...
    0010: 0a 00|00 22 00 00 2e 00 80 07 00 00 ..."....€...
  2. davexnet

    davexnet Active member

    Jul 7, 2003
    Likes Received:
    Trophy Points:
    By default, MPC is able to play back anything that directshow can render -
    howeve, it's possible some of the decoding is turned off in FFDshow (or similar)
    See this post that explains a little further:

    Install Mediainfo and open your file to get more about the audio type.

    Your audio type seems to be WMA. Try enabling the WMA type in the FFDShow
    audio decoder configuration. (set them to LIBAVCODEC).


    Uploaded with ImageShack.us
    Last edited: May 7, 2010

Share This Page