1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

yet another dvdflick subtitle not working

Discussion in 'Subtitle help' started by bbxrider, Dec 24, 2010.

  1. bbxrider

    bbxrider Member

    Joined:
    Dec 24, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    ok, the movie in question has a .srt and after installing the directVobSub, when playing the .avi in windows media player, it has the subtitles.
    when using dvdflick to create an iso, when I just select the .avi for conversion, it automatically recognized the .srt and lists it as having subtitles in the selection window, it converts ok, but no subtitles in the dvd burnt from the iso created in the dvdflick? i even did a 2nd conversion and going into edit, removed the .srt dvdflick had already picked up and specifically added it, but the again no subtitles. could I possibly need some other codec or similar to be available for dvdflick in its conversion processing?, no errors in the log file.
    baffled and frustrated here
     
  2. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,567
    Likes Received:
    40
    Trophy Points:
    128
    Verify the presence of subtitles in the ISO file - VLC can be used to play it back on the PC.
    The subtitles are selected from the top menu:'Video' > 'Subtitle Track'.
     
  3. bbxrider

    bbxrider Member

    Joined:
    Dec 24, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    ok, so with vlc and selecting subtitles, the iso playing in vlc has the subtitles, so far so good, but when i burn the iso to dvd with imgburn and play the dvd on a toshiba player no subtitles are on that playback? something with the imgburn or something with the toshiba player? in the toshiba settings there I have set it to recognize or play subtitles. dang seems like everything is there cept the final playback on the dvd
     
  4. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,567
    Likes Received:
    40
    Trophy Points:
    128
    are you pushing the 'subtitles' button on the remote during playback?
     
  5. ps355528

    ps355528 Active member

    Joined:
    Aug 17, 2010
    Messages:
    1,050
    Likes Received:
    17
    Trophy Points:
    68
    yah indeed.. it's a player setting.. or just maybe it can't handle the chosen font setting? Sometimes making sure it's stock serif helps.. some players can't handle verdana or alternatives so display nothing even when there is a subs stream present.
     
  6. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,567
    Likes Received:
    40
    Trophy Points:
    128
    DVD Flick will let you set the subtitles on by default.
    Even if the subtitles are not set on the player, they will play automatically - then you can use the remote to turn them off.
     
  7. bbxrider

    bbxrider Member

    Joined:
    Dec 24, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    yah, that was it kinda, the player is a toshiba 20DL76 about 2 years old. Turns out in the general settings there are 4 places that evidently all need to be checked, 1 is obvious, it is called 'subtitle language', the other 3 are 'playback/disc menu language', 'playback/audio language', and 'display/OSD language' they are all either off or check next to the language that you want'. all along I had the subtitle language checked to english but until I went in and selected the other 3 to english as well, no subtitles on the playback.
    best thanks is for the tip that VLC plays the .iso, so you at least know what the final product has or has not.
    and the big lesson for me is to scour the player for anything that might even be close to subtitles and enable them all.
    made my christmas merrry, thanks to all
     

Share This Page